You are here

Wacom Tablet Pen

Hi - I just installed GIMP and I'm having a problem with my Wacom Tablet Pen. When I use it, which it is the only thing I use, I don't use a mouse, it will move across the screen for a second and then freeze. Is it not compatible with this program, I've never come across that before if it is the case, and if it isn't is there something I need to change in my settings in this program or my computer settings? I'd appreciate any help you can give me. Ever since I've been running Vista I have had nothing but trouble with image editing software - it's starting to drive me batty!! Thank you in advance for any help given.

Lori

Forums: 

I have been having the same exact problem. I use XP, so it is probably not vista giving you this problem but GIMP itself. Which is a shame because it's the perfect program if it were not for this very annoying flaw. I to would like to know if there's anything to fix this.

Try going to the Tablet Driver Preference File Utility and clear it out and restart GIMP. I used to have the same problem but it worked after I did that I believe. The only problem now is that my computer sucks so bad my tablet driver crashes when running with another program. Go figure. :P

My tablet was half working too. I could move the cursor, but couldn't paint or erase. I went to preferences and pressed reset and it's working!

Duplicate of this bug- http://registry.gimp.org/node/5584 GTK bug and fix: http://bugzilla.gnome.org/show_bug.cgi?id=496958#c24 I tried the fix on the bug report, edited the binary with a hex editor and can confirm this works with Gimp 2.4.6. If you don't fancy hacking the DLL yourself you can download it here: http://dump.bitplane.net/gimpfix/libgdk-win32-2.0-0.dll Close GIMP, download the DLL, copy it to "c:\program files\Gimp 2.0\bin" and restart GIMP. The problem should be fixed :) The file size is different because I have UPX in my "Send To" menu, no malware I promise! Also this is technically a GPL violation, so expect it to go offline as soon as the FSF threaten to sue me ;)

I'm running a Wacom Graphire 3 under windows vista (ya its not linux but I have to keep windows for warranty reasons - which sucks)

This gadget has both a mouse and a pen - it is my only pointing device

I applied the patched .dll but it seems to work when it feels like it.

Either I have the mouse - with the tool displaced from the pointer - and the pen won't work

or I have the pen working correctly and no mouse

Wacom is a pretty popular tool so maybe this needs sorting out

Nick

The problem with Wacom Tablet is a bug with the GTK toolkit. I submitted a bug to buglist several years ago and it has been tossed around since then but no solution has been submitted. The bug has to do with relative vs absolute positioning (mouse vs pen mode). Any program that uses the GTK toolkit has this problem (Gimp, Calibre to name a couple).

There hasn't been any activity for some time so a fix does not appear to be forthcoming.

David

The original description seems to be different from https://bugzilla.gnome.org/show_bug.cgi?id=154657 (this is the absolute vs. relative mode problem), though.

Subscribe to Comments for "Wacom Tablet Pen"