You are here

Wavelet Sharpen-0.1.2 Windows 32 binary

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

A new Windows compilation of the last version of this fine plugin written by Marcor.
No console window. Compiled with LDFLAGS=-mwindos as usual.

(2009/12/26) New compilation of same sources. French localization added. Locale dir fixed this way:
LOCALEDIR = /PROGRA~1/GIMP-2.0/share/locale
Which means (any drive)/Program Files (or Programmi, and so on...)/GIMP-2.0/share/locale for your language files.

The archive contains two directories:

- GIMP-2.0 should be decompressed to your GIMP-2.0 directory in order to get the translations (if they exist in your native language: LANGUAGES = de ru it pl et fr) If you expand the whole dir to you Gimp dir, you will not have to care about the complete path of the translations files.

- plug-ins, either to (drive letter):\Program Files\GIMP-2.0\lib\gimp\2.0\plug-ins\ or c:\Documents and Settings(your user name)\.gimp-2.6\plug-ins\ I recommend the latter.

[16th June 2010 Update]:

As some antiviruses displayed a false alert with the executable, I replace it.

If you prefer an automated installation without browsing all those directories, you will find one in this page: (then look for

If you choose the installer, please don't put it into the Gimp plug-ins folder: extract the installer from the zip file, execute it from your desktop (for instance), then you can delete it. The installer is supposed to copy the files into the right folders.

wavelet-sharpen-0.1.2_win32.zip17.72 KB
GIMP Version: 
Code License: 


this wavelet-sharpen appears fine in 2.7.1 from with a CLEAN install of 2.7.1.
I had to remove all vestiges of old versions of GIMP and .gimp-2.6 stuff in %USERPROFILE%\ created by mathmap. I simply extracted the whole package into the plugins directory.

I just got massive quantities of plugins to appear in 2.7.1, with my package installer - GIMP is now huge and wide.

how do I compile this package? I would like to try my hand at compiling this package for windows, but there doesn't seem to be a gimptool in the one at so I can't compile plugins. I have no idea how you are doing it.

I put together a GIMP package that is full of already-done resources and plugins. it gives about 13 errors on startup, but once it starts up, you have just about every useful plugin available.
since I know that this is not an advertising site, I am not going to give the URL unless someone asks.

no gimptool for windows but

you may well post the url for gimp plugin (and even scripts or resources) in this is the gimp plugin registry !

do you use mingw+msys to build gimp+gtk, and then gimptool upon which you build wavelet sharpen?
am I understanding the toolchain correctly?

btw, mingw-w64 is much better and more up-to-date and has TR1. I usually use the "personal" builds under "toolchains targeting 32/64-bit"

btw, this version of wavelet-sharpen works in look for 2.6.10 that version works just fine and boy does it like plugins (python, scheme, and .exe support)!

it turns out 2.7.1 is alpha or beta and has a bug which is not fixed yet - you can't insert text.

There is a gimptool for Windows, but you don't need it with Marcor's plugins. There is no configure either. You must edit the Makefile in /src/, and add

LDFLAGS = -mwindows

after the CFLAGS line.

Also add the LDFLAGS to the plugin compilation line:


$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)

C plugins make very small executables, most of the time less than 100 kb. If the .exe seems too large (in some cases the strip option does not work), don't be afraid to type "strip wavelet-sharpen.exe", for instance. If there was some debug code left, it will be removed. If not, the file is touched but not modified.

No, I'm using v 2.6.8.


maybe the last version of this plugin is TOO updated
Work well in gimp 2.7, should work even in the future 2.8, but has problem with the stable version

Because search for newer libraries( in win dll ) that are only in gimp 2.7 , and do not accept the older that are in 2.6

I was mirroring the previous version that work well with gimp 2.6

EDIT ..oopss i forgot the link

download link at right side of illustration (sorry i can't hot link )

you didn't solve yet ?

There is a new stable version of gimp is possibe that install that and installing the plugin not by dropping in a plugin folder but using Gimp Edit/preferences/folder (expand "folder "here ) plugin may solve

in case just unzip in a new folder (were the folder is not relevant..may be Document ) and add the path for the folder there and reload gimp

Either I'm doing something wrong or there's something wrong with this distribution! I have now tried to install it on two Windows 7 (home premium) computers and one Windows XP-Pro computer. All failed.

I installed it by copying the WaveletSharpen.exe to the Gimp plug-ins directory. When Gimp was loading it failed to load WaveletSharpen because of missing DLLs -- libintl-8.dll, libiconv-2.dll, msvcr80.dll. In each case, I found the DLL and put it in the same directory. Finally, I got the error, "The procedure entry point _inittesme_e could not be located in dynamic link library msvcr80.dll."

The older version of WaveletSharpen works fine in all of these computers.

I find WaveletSharpen quite effective and would like to use the latest version. Any thoughts?


are you using the "beta" version..gimp 2.7.1 ?

Just installed it François; looks great and thanks for compiling it for me. :)


Subscribe to Comments for "Wavelet Sharpen-0.1.2 Windows 32 binary"