You are here

Low Frequency Even ver 1.1 (UPDATED)

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

This plugin removes low frequency brightness and color differences from image. It's dedicated for creating textures for computer graphic from photos. But it shuld be usefull for other puroses too.

It works fine also for images with non unfiorm structure (bigger details with different brightness color)

For images which contains few big details you can:
- Use bigger filter value
- Disable filtering one of axis (X or Y)
- Erase unwanted details from image (to transparent)
- Select only wanted details

So, for filter this image:

I first selected grass areas, feathered selection and applied the filter. After that I inverted selection and filtred it again.

Installation: Copy script dedicated fr your GIMP version into Script-Fu scripts directory
To run fiter: go Filters/Light and Shadow/Low frequency even

    Changelog:
    • Version 1.1
    • "tmp-layer error" fixed
    • Added GIMP 2.7 and above support
    • Version 1.0
    • Initial release

DOWNLOAD:

GIMP Version: 
Scripting Engine: 

Comments

I have just used this plug in to even out a flash photo of a circuit board which I am turning into line-art - eventually vectors. On a 2602 x 3906 photo with radius set at just 6 pixels (the width of a track on the board) it took ages to process, but the result is fantastic - albeit with the black, white and copper areas now entirely in shades of green. This has saved me so much work! I'll play around with the settings a bit, but really, Miran, thank you so much!

(NB, the project is to eventually produce a schematic from the photos. I've never done it before, so it's all learning. Not having a "flat" photo to start with is a big setback)

well it seems excellent

WARNING: Plug-In "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-drawable-is-layer'.
It should call 'gimp-item-is-layer' instead!

WARNING: Plug-In "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-drawable-get-image'.
It should call 'gimp-item-get-image' instead!

Plug-In 'Low frequency even' left image undo in inconsistent state, closing open undo groups.

Thanks for info.
I created version for GIMP 2.7+, and also fixed bug I found.

Are you planning to release a version for GIMP 2.8?

that is one of the disadvantage of using unstable beta version of Gimp

...or the script will give warning if used with the stable version (and that will be very bad) but not with that beta...
Or will work fine with the stable but not with 2.7

anyway you may open the script with a text editor , replace each instance of 'gimp-drawable-is-layer' and "gimp-drawable-get-image' with 'gimp-item-is-layer' and 'gimp-item-get-image'...that should fix

Of course the modificated script will not work anymore with the stable version but only with 2.7

Your preview results look pretty good. I've been using RobA's Retrobe Highpass filter to help giving similar results that you are getting, but I think most of the time, all I really need is low pass evening. I'm about to download your gem now. Thanks. :)

Pages

Subscribe to Comments for "Low Frequency Even  ver 1.1 (UPDATED)"