You are here

Compile Save For Web Plug-In

How can I compile this plugin?
When I try ./configure the output is:

checking for GIMP... configure: error: Package requirements (gimp-2.0 >= 2.3.0 gimpui-2.0 >= 2.3.0) were not met:

No package 'gimp-2.0' found
No package 'gimpui-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GIMP_CFLAGS
and GIMP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I have the gimp installed in the directory /usr/sparazza/.gimp-2.4
can you give me an hint?

Cya
Sparazza

Unfortunately, the error you get there is although correct, a bit incomplete, at least in my humble opinion, it should tell you that you should check if libgimp2.0-dev is installed. Check if you are missing the package libgimp2.0-dev, described as Headers and other files for compiling plugins for The GIMP. If you don't have this installed, your system doesn't have the necessary information needed to compile a plugin for GIMP (happened to me also). So, if you are on Ubuntu: sudo apt-get install libgimp2.0-dev ./configure make sudo make install Enjoy, and thanks to whomever built the plugin!

Solved with the .deb file for Ubuntu, but I installed also the libgimp-dev to avoid future compliling problems Thanks to all cya Sparazza

I followed your instruction and all worked well. Thanks.
Subscribe to Comments for "Compile Save For Web Plug-In"