You are here

Adobe PS CS3 Plug-ins

Will GIMP 2.6 support PS CS3 plug-ins?

If so, how do I install? I attempted to use the GIMP Plugin Browser but it showed nothing as I browsed the PS filter folders.

Thanks in Advance

Found my answer. Well I thought I did. But it does not work.

I took the IMpressionist plugin and installed it in the following folder:

C:\Program Files (x86)\GIMP-2.0\lib\gimp\2.0\plug-ins

This looks like the place where all the standard GIMP plugins are.

I get no error and do not see the "Impressionist" in the filter menu.

Any help. I'm assuming this plugin works based on another forum thread. The other thread mentioned the file "pspirc" but I do not find that on my system anywhere.

Thanks

If the plug-in isn't either a py or executable, you're going to need to use PSPI to use those plug-ins.

http://registry.gimp.org/node/196

PSPI.exe needs to be placed in C:\Program Files\Gimp-2.0\lib\Gimp\2.0\plug-ins

As for specifically created Photoshop plug-ins (CS3, etc) I'm not sure if they are compatible. For instance, OnOne's Photo Elements plug-ins can't be used anywhere except Photoshop.

Once you have added the PSPI, some advice:
1. I wouldn't place my Photoshop plug-ins in my Gimp plug-ins folders, instead create a new folder for the plug-ins (the name and location of this folder isn't critical) and point to it using PSPI (it shows up under Filters once you add it and reboot GIMP).
2. Any plug-in with accompanying dll files or secondary sub-folders (some plug-ins have environmental and language files that go with it), I would separate these type of plug-ins and place them in their own folder (not loose in the plug-ins folder you create) and point PSPI to them as mentioned in #1.
3. PSPI doesn't like plug-ins that aren't UTF-8 encoded, and because of this, if you download, say a plug-in written in a foreign language that introduces character sets that aren't UTF-8 compatible, it's highly likely it will break PSPI and cause errors for all the plug-ins you have installed.
4. Installing duplicate plug-ins also causes errors, where you don't see the error prompts but when using the plug-ins, they just don't work at all. (This happens a lot, when I upgrade plug-ins and forget to remove the older version)

in few words
1 ) you may use most (not all) of the "PS compatible" plugin following the advices of malvhin
(see his message)
2) you can't use any plugin designed specifically for PS CS
Not only Giimp but no any other program may do it

Subscribe to Comments for "Adobe PS CS3 Plug-ins"