You are here

photoshop plug-ins in Gimp

Can anyone help me get the Alien Skin Eyecandy 6 plug-in working in Gimp? I'm not sure if it is even possible. I know I need to use pspi plug-in, which I have done, as well as putting all the eyecandy plugins in a folder so that I can load them when I use pspi in Gimp. When I go to use them, I can see them all listed as if they were going to work, but when I actually try to use them, nothing happens. I know there is a way to make it work. I just don't know what that way is or if anyone else has done it yet. It would be great if someone created the equivalent filters for Gimp, but Eyecandy is a fairly well designed commercial filter set. If anyone has any ideas, please respond. Thanks.

Some plugins just won't work in GIMP. This is one of them (I have an older copy of it and use Irfanview as a surrogate via copy/paste for GIMP use). If you do get it to work, then that would be cool. I just wish PSPI would be re-written by someone even if it would no longer be technically open source so that all PS plugins would work, but have not heard of anybody actually getting the PS plugin SDK to do this. Oh well. :)

The PS CS SDK is available as a free download.

I tried to compile the PSPI plugin against it (windows of course) and got so many errors I don't know where to even start.

The current PSPI will only compile with the PS6 SDK.

-Rob A>

Impressionist worked in PS 6 Rob; have you tried running that plugin in GIMP with your compile?

http://asnailpace.com/blog/impressionist-plug-in/

I did get it to work, but there were a couple extra steps, as the pspi plugin errors then blocks it from running.

After unzipping the file into the directory you have specified for PSPI plugins, and BEFORE Starting GIMP:

  1.  The two files: MSVCRT10.DLL & plugin.dll can't stay in that directory, so move them to c:/windows/system (as suggested, unless you already have them there, in which case delete them or change the extensions from dll to something else)
  2. Start Gimp. PSPI will error, and you won't see the filter.
  3. Quit gimp.
  4. Open the file in your personal .gimp-2.6 folder called "pspirc" using a good text editor (I use notepad++)
  5. Search for Impressionist. You will see it is like so:
  <ps-plug-in path="path_to_your_ps_plugin_directory\Impressionist\Impressionist.8bf" timestamp="867643200">
  </ps-plug-in>
Add the following line:
    <entrypoint menu-path="<Image>/Filters/Impressionist/Impressionist..." image-types="GRAY* RGB* " entrypoint="ENTRYPOINT1"/>
  before the </ps-plug-in> line. (It should look like the other entries in this file)

 Run gimp, andthe plugin will now be available under Filters->Impressionist->Impressionist.

 As another note, it only seems to work on layers without an alpha channel .

-Rob A>

Cool info; might try to dicipher and give it a whirl later. Sad that alpha channel layers have issues (haven't even thought about it when I run CS2 and Irfanview doesn't support Alpha anyway, so it wasn't an issue). Thanks again for the info. :)

Edit:

Thankyou, thankyou, thankyou. Works like a champ. Going to brag about you now at DPR's Retouching forum and maybe a few others. :)

And thank you Lyle for directing me here to this solution.
It works excellent now.

And thank you Lyle for directing me here to this solution.
It works excellent now.

I was looking for a guide to get this to work thanks so much ffaat

From the way you describe the problem, it might be one of several things.

1. You have duplicate scripts or plug-ins, in both GIMP sharing folders (Program Files and Users locations). This should give you GIMP errors, though.

2. You have plug-ins or scripts that aren't written in English, (the German umlaut, for example, will block ALL of your PSPI plug-ins since it is invalid UTF-8 and it may not give you any warning). This means that the PSPI will still recognize the plug-ins in your folder, but fail to initialize any of them. I had to sort through every plug-in one by one (a pain to do but necessary).

3. The most common problem of all, is that you may have one or more plug-ins that are not compatible by type still residing in a folder of plug-ins that are compatible. One bad plug-in spoils it for the rest. I suggest you make a new test folder for your plug-ins, point GIMP to it, and start adding plug-ins into it one at a time. That way you can remove the incompatible plug-ins to a separate folder.

Thanks for the suggestions. I have had no luck yet, but I am becoming more and more familiar with GIMP's built in filters. For the most part they are quite impressive, to say the least. Eyecandy is probably one of the more complex filter sets for photoshop, not to mention that it costs money, which probably means that they have ways of keeping people from using it in anything but photoshop. Not that there is not a way around that, but it would be beyond the scope of my ability.

Hopefully I will be able to find some comparable filters here in the registry that will replace some of the effects I was hoping to get with Eyecandy. Then again, even if that is not yet possible, there is no reason why it shouldn't be tomorrow.

I have a very old copy of Eyecandy (version 3) and it works perfectly in GIMP. Don't have 6 though, so not sure if it's a GIMP issue (like Impressionist was) or just won't be compatible with GIMP period type of issue. :)

Hope Rob doesn't mind, but he was able to get XNView to work with GIMP so now, for the most part, PSPI issues are no longer a problem. Follow the thread below for more info. RobA for coder of the year I say (not my idea; Mahvin said it first, but I 100% agree).

http://www.gimpchat.com/viewtopic.php?f=9&t=970 :Note, Rob did add something for me that makes it more friendly to embedded alpha layers; just scroll to page 3 for details. :)

The XnView.py plug-in works well in Ubuntu 10.04. Great job, RobA! Just a gentle reminder for anyone who visits the link in Lyle's post above. Get the last zip file (page 3), unless of course Rob updated all his zip links, which I am not sure about.

I can say goodbye to my PSPI issues in GIMP 2.6.11, for now, at least. :)

Subscribe to Comments for "photoshop plug-ins in Gimp"