You are here


  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

I just notice that MathMap one of the better Gimp Plugin is not listed here.
To present it i just quote its developer Mark Probst
MathMap is an image processing application that works on several levels:

* Without any prerequisite knowledge about image processing, one can use any of the more than one hundred filters that come bundled with MathMap.

* More advanced users can combine filters intuitively in the Composer, as pictured above.

* For expert users MathMap provides a simple but very efficient programming language. This is the core of MathMap and the language that almost all MathMap filters are implemented in.
MathMap can be used as a GIMP plug-in as well as a command-line tool. It is distributed as Free Software under the terms of the GNU General Public Licence.

a screenshoot of one of the most interesting feature, the Composer that allow to chain several filters


The Mathmap Gimp plugin is available for Windows and Linux (for Mac there is a older, standalone version )
For more info, documentation screenshoot ,source code and video presentation see


GIMP Version: 
Code License: 


Does this version of the plugin work with GIMP 2.8? I can't seem to get it to, but I could be doing something wrong.

Hi. I just installed MathMap on both an XP and a Vista machine..

However, when I launch GIMP I get the following 2 errors on both machines:

First error message:

This application has failed to start because libgslcblas.dll was not found. Re-installing the application may fix this problem.

Second error message:

pspi.exe Message
pspi: LoadLibrary() failed for C:\Users\Owner\.gimp-2.6\plug-ins\libgsl.dll: The specified module could not be found.

I did re-install more than once and still get the same errors. Both those dlls are in the plug-ins folder.

Can anyone help?

Looks a nice application. Forgive me my ignorance I dont know how to install. The site gives me also no directions. I am using Ubuntu64 9.10.

What to download as I see:
- chpp_0.3.6-1_amd64.deb
- mathmap_1.3.5-1_amd64.deb
- mathmap_20090822-1_amd64.deb

And how to install as standalone or Gimp plugin?

First, it appears there are two Mathmap files here that are different versions. "mathmap_20090822-1_amd64.deb " is probably the newer version.

Double-clicking the .deb files in the Ubuntu file manager should open the "gdebi" installer that will give you a description of the package along with an "Install" button. Just click that button and enter your password when asked to give install permission.

Otherwise if that doesn't work, move the files to your desktop and run the following command:
cd ~/Desktop; sudo dpkg -i chpp_0.3.6-1_amd64.deb mathmap_20090822-1_amd64.deb

Thanks for the presets PC; didn't have a few of them. Already new about one of the Droste presets being buggy (the main one that comes with Map>Droste works fine though). :)

Now everything should be fixed.

I uploaded just few minute ago, now not any filters should give warnings or parse errors

About the additional droste the problem was just in the (filter) name

You will not need is the previous version but may be more adapt for who use the first time, may do all the essential but is less complex and look less intimidating

PS the Painini codes were create for a very specific purpose

But i may assure they may be used as excellent and quite advanced distort filters

Thanks; just replaced them but didn't really see (still have issues with the new Droste versions; oh well) anything that was an issue before. :)

i just uploaded a collection of additional "custom" filters for mathmap here

I installed the new filters into my expressions folder and when calling the plug-in through GIMP, I got multiple errors about duplicate filters, and one of the new map filters (4Multi-plane perspective) causes Mathmap runtime errors which closes the plug-in.

thank to report maybe some clones slipped in.

just delete 4Multiplane for the moment and please let me know what version of mathmap and wich OS you use

In case was the Windows alpha of Mathmap, that includes several filters not in the linux version.

Basically if you use for the windows alpha of MM 1.3 you may remove all the "Update_Compositing " folder.

For the error for the Droste , the 2 droste are not clones but for the filter name

you may just, in the "expression tab of mathmap at the first not commented line that starting with
"filter droste" correct 1 of the 2 in "filter droste1" and then click
on the save button

Let me know if you find other errors please, so i may correct everything in a short time (as for tomorrow)


Subscribe to Comments for "MathMap"