You are here


  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

Watermarks a bunch of photos with the watermark file specified. Files are output to the ./WM subdirectory in the format specified.

The watermark is applied with a difference mode overlay in the bottom right corner. Let me know if something should be parametrized.

I run this script like so:

gimp -i -b '(python-fu-watermarker RUN-NONINTERACTIVE "{PATH-TO-FILES}" "{PATH-TO-WATERMARK}" "jpg")' -b '(gimp-quit 0)'

watermark.py3.54 KB
GIMP Version: 
Code License: 


I gave it a try, it seems like to runs fine and everything but when I check the photos there are no watermarks. Is it possible that my watermark image is the incorrect dimensions?


The script is tagged for gimp 2.6 / 2.7 but the menu used in the registration path (TOOLBOX/xtns) does not exist anymore, neither may be created in gimp 2.6 (now toolbox can't have menu).

Not sure if Gimp 2.7 still will take care to remap the menu somewhere else and where

there isn't too much documentation about writing these plugins. if you feel that the plugin should be placed elsewhere, send me an email and show me how I'd go about moving it there. Currently this plugin shows up under Filters>Batch>WATERMARK.

"Currently this plugin shows up under Filters>Batch>WATERMARK."

Show up there ...but almost by miracle:

this is how you registered , point is last line

"Add a watermark to an image",
"Help Computer",
"Dave Lichterman",
">Toolbox< /Xtns/Batch/_WATERMARK",

Now to register in Filters>Batch>WATERMARK
correct path should be instead

">Image< /Filters/Batch/_WATERMARK"

till now all scripts attempting to install in the Toolbox menu (that went MIA) are automatically remapped in a existing menu by Gimp.

But may be better give directly the correct path to new scripts

PS i have to invert the arrow in ">Image< and >Toolbox<
or they would be not displayed

i've updated the script. it should be better now :)

I believe that plugins whose menu parameter starts with Toolbox>/Xtns show up at the bottom of the Filter menu. For example, the plugin that registers with menu parameter Toolbox>/Xtns/Batch/Batch Process shows up in Filter> Batch>Batch Process. David's Batch Processor. It must be Gimp futzing with the given menu path (automatically, so to speak.)

Old documents show that the Toolbox dialog in older versions of Gimp had a menubar where such plugins appeared.

(Note there should be a less-than character in front of Toolbox> above, but I couldn't figure out how to escape it for this website html processor.)

plashless, off banks of noon


I can not find the script in Gimp - where are it???

sorry for my bad english - I'm German

Lieben Gruß


First is a python script so if you use windows and you have no all python module installed will not show up or will not work
then script even if dated 2009 use a obsolete path


all toolbox menu are now removed or better trasferred to other menu but i am not sure where in this case

But again if you use windows may be complex use phyton script (here a how to)
But even them i suppose that menu path should be corrected

Should be similar script but in scheme (scm) that you may use without need to hack to install python support for gimp

Subscribe to Comments for "Watermarker"