You are here


  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

DustCleaner is a GIMP plug-in to automatically detect and remove the dust spots in digital images. It was registered under the menu of filter->noise.

Up-to-date binaries and source code can be found here:
Demo can be found here:

Currently, I only build the executable on x86 Linux. If someone has successfully built it on other platform, please let me know, thanks in advance!

My email is, contact me if you get any question about this plug-in.

Enjoy~ :-)

GIMP Version: 
Code License: 


but after a little testing in gimp is not so useful for my needs anyway!


look at this little image:

i want to erase that little isolated dusts and keep letters untouched! hard to get this result i played a lot with dustcleaners variables and everytime i see only parts of letters selected and not that small & isolated dust!

damn! not so god! default gimp despeckle plugin is also unable to erase only small & isolated dust points and always touch the letters. unwanted result here:

as you suspect i search for a perfect image "binarization" useful in a further perfect OCR processing ... what settings can be used to select smaller dust and leave letters untouched!? i do not find any useful settings in dustcleaner until now


final result should be like this:

i can get this beautiful Black & White "clean" 1-bit image using a combinations of gimp and gmic filters but with aggressive settings that can erode dangerously letter contours if you apply this filters to full camera images with nonuniform illumination

my hope was that dustcleaners gimp plugin can help me more than aggressive gmic hot pixels filters ... no luck until now ...

after i solved this two small problems i can build dustcleaner in sabayon linux amd64 kde with this steps:

cd /usr/local/dist/gimp/plugins/dustcleaner/svn
./configure LIBS=-lcv

a second "forced" « ./configure LIBS=-lcv » command is required, a simple


is not working i get a lot of "undefined reference to `cv***'" functions errors and then build will fail ... so, « ./configure LIBS=-lcv » command IS REQUIRED!

cd src

file dustcleaner
dustcleaner: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped

./dustcleaner is a GIMP plug-in and must be run by GIMP to be used

OLE! a working x86-64 linux executable!
cp ./dustcleaner ~/.gimp-2.6/plug-ins

second try with an edited

I am testing that you have the required versions of autoconf,
automake, glib-gettextize and intltoolize...

checking for autoconf >= 2.54 ... yes (version 2.68)
checking for automake >= 1.6 ...
You must have automake 1.6 or newer installed to compile GIMP Plug-In Template.
Download the appropriate package for your distribution,
or get the source tarball at
checking for glib-gettextize >= 2.0.0 ... yes (version 2.28.5)
checking for intltool >= 0.17 ... yes (version 0.41.1)

Please install/upgrade the missing tools and call me again

yeah, me using autoconf-10 and autoconf-11! anyway easy to fix:

sudo equo install sys-devel/automake-1.6.3
>> @@ Calculating dependencies ...
>> ## [N] [] sys-devel/automake-1.6.3|2
>> @@ Packages needing to be installed/updated/downgraded: 1
>> @@ Packages needing to be removed: 0
>> @@ Download size: 349.6kB
>> @@ Used disk space: 1.1MB
>> @@ You need at least: 1.8MB of free space
>> :: (1/1) >>> sys-devel/automake-1.6.3
>> ## Downloading archive: automake-1.6.3.tbz2
>> ## ( mirror #1 ) Downloading from:
>> ## ( mirror #1 ) Successfully downloaded from: at 208.1kB/second
>> ## Package checksum matches: automake-1.6.3.tbz2
>> ++ (1/1) >>> sys-devel/automake-1.6.3
>> ## Unpacking package: automake-1.6.3.tbz2
>> ## SPM: pre-install phase
* Package: sys-devel/automake-1.6.3
* Repository: gentoo
* USE: amd64 elibc_glibc kernel_linux multilib userland_GNU
* FEATURES: preserve-libs sandbox
>> ## Installing package: sys-devel/automake-1.6.3
>> ## [Used to generate from]
>> ## Updating database: sys-devel/automake-1.6.3
>> ## Cleaning previously installed application data.
>> ## SPM: post-install phase
>> ## Cleaning: sys-devel/automake-1.6.3
>> @@ Installation complete.
>> @@ Configuration files scan complete.

again, in maybe is better to have more checks for never automakes?

echo -n "checking for automake >= $AUTOMAKE_REQUIRED_VERSION ... "
if (automake-1.7 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.8 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.9 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.6 --version) < /dev/null > /dev/null 2>&1; then
echo " You must have automake 1.6 or newer installed to compile $PROJECT."
echo " Download the appropriate package for your distribution,"
echo " or get the source tarball at"

should be:
elif (automake-1.10 --version) < /dev/null > /dev/null 2>&1; then
elif (automake-1.11 --version) < /dev/null > /dev/null 2>&1; then

equo search sys-devel/automake-1 --quiet

automake v1.11 is latest ...

first error after a quick

svn co

./ line 1: 2#!/bin/sh: No such file or directory

this is not good! as you can see here:

should be

Thank you for updating the plugin. Can someone please build a Linux variant?

I really want to try this plugin, I am using Gimp 2.6.8, but...

After downloading I try to extract the file and get this error:
zip: stdin: not in gzip format
tar: Child returned status 1
tar: Exiting with failure status due to previous errors

Can't see any file to download on

Who can help me out?

Sorry for the inconvenience. I've updated the x86_32 binaries on Please have a check.

So you finally released it? :)

Hi, yes, although it's not stable so far, lots of works need to be done. Thank you~

Attaching ELF binaries is a bit uncommon, at least without also adding the source code - I've hidden it because of this.

Could you be a bit more verbose about the platform where this is supposed to run on? And where is the source code for this plug-in?


Subscribe to Comments for "DustCleaner"