You are here

Advanced troubleshooting? (scripts are not recognized)

Hello,

at http://docs.gimp.org/en/install-script-fu.html they say:

"The script will now appear in one of your menus. If you don't find it, look for it under the root file menu filters. If it doesn't appear at all, something was wrong with the script (e.g. it contains syntax errors)."

I have installed several scripts (into the right directory, double-checked) but I don't find anything anywhere...

(I have restarted Gimp several times, I have hit the refresh button...)

What can I do?

PS: I am working with Linux and Gimp 2.6.12

OK, let's take this one step at a time.

Please point us to a single script that you have tried to install:- i.e. a link to the page where it can be downloaded.
List every step that you take to install it, with as much detail as possible - don't assume anything, be explicit.

Kevin

I tried several for being sure that I didn't just got a bad script. But all of these are not appearing:

http://registry.gimp.org/node/20269 -- Draw Arrow
http://registry.gimp.org/node/9592 -- National Geographic Script
http://registry.gimp.org/node/184 –– Amazing Circles
(all scripts are declared as suitable for Gimp 2.6)

Let's focus on the last one.

1. I download Darla-AmazingCircles.scm.
2. I copy the file into the right folder (which is in my case: /home/oliver/.gimp-2.6/plug-ins ).
3. I restart Gimp (probably not necessary).
4. I refresh the Scripts.
5. I don't find anything... (for my search I also tried menu "help->plug-in-browser" and "...->procedure-browser". But the number of scripts / plug-ins / procedures is always the same there: 268 plug-ins and 1058 procedures)

Meanwhile I also tried:
6. to change the file permissions (I made every script "chmod 0664 ...") Or do the scripts need to be executable ?
7. to copy the scripts into the second directory that contains scripts (/usr/lib/gimp/2.0/plug-ins) as declared in the general gimp configuration

for some reason I was blind for the fact that gimp has different folders for plug-ins, scripts and modules...

so I did not have the right folder...

now, I copied the files to /home/oliver/.gimp-2.6/scripts ... and there is another main entry in the menu bar: "Script-Fu". There I see already two of my installed scripts, and I discovered some more ... great!

thanks for your good will to help me.

Subscribe to Comments for "Advanced troubleshooting? (scripts are not recognized)"