You are here

Advanced Unsharp Mask

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

Sharpening tool, uses blurred mask. Sharpness is modified with few sliders that work like a kind of equalizer. User can control blurring parameters (radius and treshold for selective blur mask). It provides 4 types of output: Sharpenned image, mask, split/comparision mode and mask-to-img differences.
Brightness of image can be affected by levels-like tool that works indirectly - via the mask.
See attached screenshot for more info.

Plugin is multithreaded.

Downloads (source code with instructions for linux) and few sample images

Any comments and feature requests welcomed.

GIMP Version: 
Code License: 


With your suggestion it compiled in a few seconds.

Thank you very much for the information. Perhaps adding a line with this information to the readme.txt?

yes, adding a line into readme.txt would be appropriate, but I can not issue a new version just to change a README.txt file ...

Compilation on linux 64-bit failed. Here is the output:

reginald@linux-9rfb:~/Downloads/aumask> gimptool-2.0 --install aumask.c
gcc -pthread -I/usr/include/gimp-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/libpng15 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -o /home/reginald/.gimp-2.8/plug-ins/aumask aumask.c -lgimpui-2.0 -lgimpwidgets-2.0 -lgimpmodule-2.0 -lgimp-2.0 -lgimpmath-2.0 -lgimpconfig-2.0 -lgimpcolor-2.0 -lgimpbase-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0
aumask.c: In function ‘run’:
aumask.c:273:3: warning: ‘g_thread_init’ is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:259) [-Wdeprecated-declarations]
aumask.c: In function ‘do_mask3’:
aumask.c:578:4: warning: ‘g_thread_create’ is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:100): Use 'g_thread_new' instead [-Wdeprecated-declarations]
aumask.c: In function ‘do_final’:
aumask.c:658:3: warning: ‘g_thread_create’ is deprecated (declared at /usr/include/glib-2.0/glib/deprecated/gthread.h:100): Use 'g_thread_new' instead [-Wdeprecated-declarations]
/usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: /tmp/cc4kwUH3.o: undefined reference to symbol 'pow@@GLIBC_2.2.5'
/usr/lib64/gcc/x86_64-suse-linux/4.7/../../../../x86_64-suse-linux/bin/ld: note: 'pow@@GLIBC_2.2.5' is defined in DSO /lib64/ so try adding it to the linker command line
/lib64/ could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status

Version of glibc is 2.17-4.4.1
Version of Gimp is 2.8.4

Any help appreciated

Thanks in advance

two problems are mixing here, first 'g_thread_* is deprecated' - this is just warning, everything still works, I keep old API for older linux versions - in fact older glibc versions (on my debian stable it compiles without warnings)

But the real problem is 'undefined reference to symbol 'pow@@GLIBC_2.2.5''. On arch linux I tend to fix this with
export LDFLAGS="$LDFLAGS -lm"
before compilation, let me know if it fixed the issue.


Tested only in Gimp-2.6.11


Hi all

Lately I resumed my work on this plugin and here is new version. Primary reason was that I was not satisfied with blurring algorithm for selective mask. But I reworked also internals of the plugin and did some changes to GUI and the way how the plugin works.
Most significant changes relates to an export to new layer.
Another change is that now you have four output modes and they work in the same way in preview, on original layer or the result can be exported to new layer.
I added "postblur" option to selective mask as there used to be artifacts between areas with too different brightnesses
I added some controls for "mask-to-img differences" mode (see GUI/screenshot of plugin)
Also I added mouse-over tips on some elements of GUI

Any feedback is welcomed



640 492 bytes

These binaries are tested on :

32bit ->
Gimp GIMP 2.6.11 32 bits
Gimp 2.7.4 32/64 bits
Gimp Painter 2.6.11 32 bits (Put the dll in the plugins directory with the executable)

64bit ->
Gimp 64 bits version 2.6.10 Sourceforge
Gimp 64 bits version 2.6.11
Gimp 64 bits version 2.7.5 Partha
Gimp 32/64 bits version 2.7.4 Sourceforge
Gimp rggjan 64 bits version 2.7.4 Partha


1 090 085 bytes.


Dll for Gimp Painter 32 bits from :

Nice. Thanks to you both! Ver. 0.8 works fine on my XP32bit.
(Btw, what about implementing the flexible preview into your saturation equalizer? :)) )


Subscribe to Comments for "Advanced Unsharp Mask"