You are here

mats-and frames error

I get this error when I tried to use the mats-and-frames.scm in 2.8
Is there anything I can do to make it work?
Error: ( : 1) eval: unbound variable: gimp-drawable-image

Try editing the file to change all 3 occurrences of gimp-drawable-image to gimp-drawable-get-image. This worked for me.

Just thought about this thread, I may try to edit the code.

Hi, I've the same trouble with this script. I've tried to modify log, but with no results. What can I do again? Thank you in advance ^_^
P.S. sorry for my bad english, I hope I've been understood anyway o_0

Using GIMP 2.8.4
The plugin Matte & Frames
This change, in 3 positions, to :-

(let* (img (car (gimp-drawable-get-image drawable)))

Works brilliantly many thanks,
Regards
John

I tried the fix mentioned in this forum and changed one line in three places. It did not work, now the script will not load at all. Does anyone have an updated version that works?

Thx

Try this version: http://gimpscripts.com/2011/10/mats-and-frames/ Or have a look at rayadagio's Frame Factory script: http://forum.meetthegimp.org/index.php/topic,1438.0.html

I got help from Patrick David on the web and this worked:

change all occurences of "gimp-drawable-image" to "gimp-drawable-get-image"

("gimp-drawable-image" was deprecated a while back)

Subscribe to Comments for "mats-and frames error"