You are here

Fonts in 2.8 are not displaying correctly

After installing 2.8 I went back to work on an existing image that I wanted to modify.

When I attempted to reuse the same font that was used in 2.6, it returned plain text as shown in the attached file.

I am working on a Windows 7 PC w/ 6GB RAM.

Do I have to go back to 2.6 or will a fix for this be coming shortly?

Thanks.

AttachmentSize
Font example.jpg79.67 KB
Forums: 

P.S. Most of the decorative fonts are NOT working in 2.8.

Where are the fonts installed in 2.6? If they are only in the Gimp profile for 2.6 or in the 2.6 Gimp install tree, they aren't available to the 2.8 Gimp until you copy them over.

If these fonts are installed as system fonts (available in other apps, such as Wordpad), then it would be a different matter.

Where is this Gimp 2.6 font folder?

Unless these fonts were part of the Gimp 2.6 installation file, I never installed any fonts into Gimp.

There are too many decorative fonts not working that I would think they would ALL be found in the Gimp 2.6 font folder.

See also https://bugzilla.gnome.org/show_bug.cgi?id=675781 - currently, no one is investigating that, maybe you'd like to help?

install usually sets that path automatically to the windows/fonts folder.
My install of Parthas 32 bit Gimp-2.8 works with most fonts also.
http://www.partha.com

-Rod.

I have tried all the suggestions in this thread, but it is not working.

I uninstalled 2.8, then used CCleaner on the entire system including registry. After that I double checked for any remaining folders that didn't get deleted and removed those.

I rebooted the system, downloaded a new version of Gimp 2.8 and installed it. Even though it was a clean install, I still cannot see any of the fancy fonts within Gimp. I brought up Word and played with those fonts there with no problem, but Gimp 2.8 gives a default font, nothing fancy.

Adding the C:\Windows\font to the font folder preferences did not help.

I went looking for Gimp 2.6 but can't find it and for some reason it is not in my backup. Still need to look into the archive.

Where can I get the Gimp 2.6 release? There is work I need to get done and I need those fonts working.

Thank you.

Okay, I downloaded 2.6 and installed it leaving 2.8 installed.

The first item I noticed was that 2.8 was installed in the "C:\Program Files" folder (64 bit system), while 2.6 was installed in "C:\Program Files (x86)" folder (32 bit system).

I hope that is the correct installation location for 2.8.

I started 2.6 and immediately created a new image and clicked on the Text tool. I looked for the "Clowningway thin" font, which is the fanciest font I have. It correctly displayed in the font selector and property displayed when I typed it.

I exited the program and started 2.8. Did the same thing as above, but the font was a generic and did not display like it did in 2.6.

So, whatever was done in 2.6 to make this work is not being done in 2.8.

If you want me to test anything else let me know. But since this forum does not send out email notices of posts I may not be back soon enough to see it. For now I am going to be staying on 2.6 and will be waiting for a fix to 2.8.

Hi! I don't work at Gimp or make plug in thingys. But to answer this question you asked:

Quote: The first item I noticed was that 2.8 was installed in the "C:\Program Files" folder (64 bit system), while 2.6 was installed in "C:\Program Files (x86)" folder (32 bit system). I hope that is the correct installation location for 2.8.

Apparently, I believe your installations are correct. When I installed 2.8 "FIRST" then 2.6 afterwards, (note: I used the installer packages at Gimp downloads)... 2.8 installed in Program files folder. Which is where, 64 bit programs are usually installed. Why? Perhaps there is some sort of 64 bit code etc. programmed into it. I wondered this same thing too when I realised Gimp 2.8, installed in Program files folder. He! He! Maybe Gimp guys could explain this question.
And Gimp 2.6 installed in Program files(x86). Just like my previous 2.6.11 version, was installed.

So I don't think you have to worry. The installations are probably correct. They probably install in different folders, to prevent one removing or uninstalling the other. Which does happen, if you install 2.6...before 2.8. So installing 2.8 first, then 2.6 is correct way to do it.

I hope you get though successfully, with the Font problem though. Glad I could give you good answer, to part of your problem. Hope I helped you a bit. Bye and good luck.

AFAIK on Windows gimp reads automatically the content of the windows font folder even if apparently there is not a path set for it

But set up 1 will no harm and maybe could help,
you don't need to copy the fonts somewhere else, just load gimp, enter in Edit/Preference/ folder and there expand and look for Font, then click the first icon of the dialog (look as a "new folder" icon) and then on the search icon

and find the path for your font folder (usually C: Windows/Fonts ) ...done that don't forget to click ok to confirm before close the dialogues

Gimp never was able to read all the fonts so not sure if revert to 2.6 will help much.
Apparently the 64bit portable version from Samj i am using may read most of the fonts in my system (more then 2.000 )

There are exception but till now no more then in 2.6
anyway i did not worked much with text so i can't be completely sure

The global fonts.conf file contains a WINDOWSFONTDIR directory directive on the windows platform, that's why that diretory is read regardless of the fonts directories that are set up in GIMP's preferences.

If you remove that line (and ony other diretory directives that may be present), then all font directories have to be added in the preferences.

The description of that file is available at:
http://www.freedesktop.org/software/fontconfig/fontconfig-user.html

You just helped me cut gimp's startup time by at least half. Now excuse me while I go happy-dance :)

Thanks! I deleted line 26 from fonts.conf and am now much happier with Gimp, installing only fonts that I need.
With the use of 2manyfonts hack my windows font folder is now 1,83 MB :D

did you make sure the path to windows font folder is still in Edit>Preferences>Folder>Fonts ?

-Rod

Subscribe to Comments for "Fonts in 2.8 are not displaying correctly"