You are here (can be used simultaneously with the bootchk's version)


This is a modified version of Resynthesize 0.16
This version can be used simultaneously with the bootchk's version :
The appeals process is different : plug-in-resynthesizer-old
Binaries and scripts are modified.

Check if you use a 32-bit or 64-bit Gimp for Windows.
*** Overwrite existing files. ***
Place the file resynth.exe in the plug-ins directory.
Install the dll in \bin or plug-ins directory.
Place the 2 scripts-fu (smart-enlarge.scm & smart-remove.scm) in the scripts directory.

Filters > Map > Resynthesize Old...
Filters > Enhance > Smart enlarge...
Filters > Enhance > Smart sharpen...
Filters > Enhance > Smart remove selection...

tests : Gimp 2.6.10 - Gimp 2.7.2 - Gimp 2.7.3 64 bits (Sourceforge & - W7 64bits
tests : Gimp 2.6.11 - Gimp Painter 2.6.11 32 bits - W7 64bits

EDIT 2011 07 27
2 313 573 bytes.

After installing the above 64bit files succesfully on my W7 64bit, both Resynthesize Old and Smart remove select opt to pick up a part of the picture from another area rather then from surrounding pixels.

For example, selecting a small boat in the sea, this will be replaced by the clouds at the top of the picture.

Moreover, while using Resynthesize old does not produce any errors, if Smart Remove is selected an warning box opens up withe the following message:

WARNING: Plug-In "script-fu.exe"
(C:\Program Files\Gimp-2.7.3\lib\gimp\2.0\plug-ins\script-fu.exe)
called deprecated procedure 'gimp-selection-load'.
It should call 'gimp-image-select-item' instead.

I am at a complete loss and have spent days trying to find something. I have tried installin files both directly on the Program Files folders and the user documents folders to no avail. I believe this problem is common to many, hence, if someone is kind enough to help out on this problem many will benefit.

Thank you for all you hard work and input in such a humongous project such as GIMP.

I try to Smart Remove a yellow date stamp in some green grass, and it comes out blue as the sky?

I really want something like this to work, but this one is just not presently.

Get this:

Edit it, and change "plug-in-resynthesizer" to "plug-in-resynthesizer-old."

Now it works fantastically!

I'm very excited about the possibilities of using this plugin, however, I have tried for days to get it to work with GIMP 2.6 on Windows 7 - 64 bit.
1. I tried Bootchk's version alone and it didn't work.
2. I then tried Resynthesizer-0.16b-32bits-64 bits alone which didn't work and then
3. tried both together and now I get a resynth.exe applicaton error: "The application was unable to start correctly (0xc000007b).
4. The instructions state: Install the dll in \bin or plug-ins directory. There are 3 dlls in the 64 bit folder. Are we to install all 3? I have tried installing all 3 in the \bin but it did not work; so I tried the plug-ins directory and still I get the error.

Any suggestions?


Do you use a 64-bit version of Gimp for Windows?

Here is the link to the 64bit version GIMP 2.6 on SourceForge:

Bonjour, Thank you for the quick response.
I believe I have the 64 bit installed; the program is listing under the 64 Bit directory. Is there a file that will tell me if it is actually the 64 bit version? Should I just uninstall and install from the link you provided?
The error I receive when I try to use plugin is: Error while executing script-fu-smart-remove:
Error: eval: unbound variable: plug-in-resynthesizer-old


You must have 32-bit version of Gimp.
You can install the files in the directory : \resynthesizer-0.16b-32bits-64bits\binaries-32bits

O.S. = Win 64bit , Gimp 32bit => install : \resynthesizer-0.16b-32bits-64bits\binaries-32bits

O.S. = Win 64bit , Gimp 64bit => install : \resynthesizer-0.16b-32bits-64bits\binaries-64bits

O.S. = Win 32bit , Gimp 32bit => install : \resynthesizer-0.16b-32bits-64bits\binaries-32bits

You wrote: "You must have 32-bit version of Gimp" which I can interpret 2 ways:
1. The problem you are having points to you must be having the 32-bit version of Gimp installed rather than the 64 bit; or
2. You must have 32-bit version for resynthesizer to work;

Also, at the site you directed me, there were 2 Gimp setups; which is the correct one for me to use?
1. gimp-2.6.10-i686-setup.exe
2. gimp-2.6.10-setup.exe

You can use the version of Gimp you want with this plugin.

If you use Gimp 64-bit, use the files in : \resynthesizer-0.16b-32bits-64bits\binaries-64bits

If you use Gimp 32-bit, use the files in : \resynthesizer-0.16b-32bits-64bits\binaries-32bits

Hi there,

I'm having the same problems as AntKat. I have Windows XP 32bit and GIMP 2.6.11 32bit.

I've installed the 32bit .dll files into the plug-ins folder and also the .scm files into the script folder.

The problem is when I attempt to apply the smart remove, I come up with the same error as AntKat (Error: eval: unbound variable: plug-in-resynthesizer-old). Could you please help out with this as I am absolutely stumped.

Thank you.

Subscribe to Comments for " (can be used simultaneously with the bootchk's version)"