You are here

Simple Wavelet Decompose

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

GIMP registry already has two pretty good filters that implements wavelet decompose: "Wavelet decompose" and "Wavelet Decompose Script-Fu". Despite the fact that these filters can be used to retouch images, I made his own.

The reasons for this "reinventing the wheel" are simple:

  1. The source layer is decomposed by only two new layers. I tried to do retouching in a large number of layers and have to admit: the more wavelet layers retouched, the more blurred result is. I have enough of the two layers.
  2. Only one parameter — the radius of the blur that defines the detail of High Pass.
  3. Decompose flows in the same image, where the source layer is and layers which already exists in the image is not destroyed.

Description of the parameters of script:

  1. "Keep original" — script will work with a copy of the active layer. If this checkbox is not checked, the source layer will be removed.
  2. "Orginal on top" — original layer will be placed on top of the new layers and will be invisible.
  3. "Check >128 issue" - create check layer which shows white areas on a black background that indicates errors of "GIMP wavelet decompose(grain merge) algorithm"(see and in Russian for details).
  4. "Radius" — scale of detail of High Pass layer. Actually, gaussian blur radius.

Install script as usual: copy it to the directory where GIMP will try to find their own scripts (eg, $ HOME/.gimp-2.6/scripts) and restart GIMP, if it was launched already. Script will be in "Layer" menu.

Change log:

16-Nov-2011: added "Check >128 issue" functionality

P. S. Sorry for my English

simple-wavelet-decompose.scm4.61 KB
Code License: 
GIMP Version: 
Scripting Engine: 


I use your script quiet often but now it seems it doesn't work in Gimp 2.8.0. I get two error messages:

Error: ( : 24720771) eval: unbound variable: number->string
Plug-In 'Simple Wavelet Decompose' left image undo in inconsistent state, closing open undo groups.

Any hint how to solve this? Or an update?

I'm using GIMP 2.8 64-bit and Wavelet Decompose works fine for me. I do have other issues though, but not with this particular plugin. :)


Oh; you are referring to a Script-fu; sorry about not viewing closer. I'm using wavelet decompose plugin. :)


Sorry, but I have not Gimp 2.8 up to now, therefore I could'nt reproduce this error. Can you use other two wavelet scripts temporarily? I'll fix this issue as soon as Canonical release Gimp 2.8 version in its repository.

No problem, and thanks in advance!

Problem solved, sorry, it was my fault! One of the settings files in my personal Gimp folder blocked the compatibility mode. I deleted all files, restarted Gimp, and now everything works fine, incl. Simple Wavelet Decompose :)

I'm very glad to read it. Have a nice photo! ;)

Subscribe to Comments for "Simple Wavelet Decompose"