You are here

Please help get python-fu running in Ubuntu 10.4

I just installed the Ubuntu 10.4 version of Linux and The GIMP. I copied over all my working script and plug-in directories/folders from Windows. As $whereis python confirms, Ubuntu comes with Python 2.7. I have no idea if pygtk, pycairo, and/or pygobject are ijnstalled (whereis did not find them). All I know is two things: (1) back in Windows, I had to hunt all over the place to find 2.5 versions (instead of 2.6 or 2.7, which was not easy) of Python, pygtk, pycairo, and pygobject before python-fu would load and run without spewing a lot of error messages during startup; python-fu itself shows up on the Filter menu ok and I get no error messages during GIMP startup. But, alas, none of my python-fu scrips are working. (And i am not too sure about my script-fu scripts and Photoshop plug-ins either). Has anybody gotten all this working under Ubuntu Linux? If so, HELP!
c h u c k _ p e t i t @ y a h o o . c o m

In synaptic, look for the following: python-gtk2, python-cairo, python-gobject. That's what I have installed. I'm still running Mint 9 which is based on 10.04 and my python plug-ins work fine. Check the permissions of the python plug-ins to make sure they are executable.

Another thing, what version of Gimp are you running? My install of linux mint 9 with gimp 2.6.11 has python 2.6.5 installed.

With all due respect, your theory of the problem is probably wrong. Your experience with GIMP and Python on Windows may be misleading. GIMP and Python on Windows has always been non-trivial while on Linux it is trivial ( works right out of the box.)

Python versions up to and including 2.7 were largely backward compatible (newer versions did not require other software such as GIMP plugins to be updated.) (It will be different for Python 3.0). So I don't think it is a problem with your Python version.

Python packaging on Linux usually includes those other modules mentioned (pygtk, pycairo, etc.). In other words, they are included in a standard Python distribution on a standard Linux distribution. I think that is the case for Ubuntu.

If it is not the executable permissions on the plugin files, please post the error messages. Start a terminal. Start Gimp from the terminal: enter "gimp" at the prompt and hit return. Error messages should go the the terminal. Cut and paste them into your post.

I am running Ubuntu 10.4 with Gimp 2.6 and Python 2.6.5, which to the best of my recollection is right out of the box.

You are looking in the wrong direction

Everything in Ubuntu is ready to allow you at soon you install Gimp to run python script.

BUT in linux you should give to the python scripts the permission to run, if not you may just read them but not use.

In Windows that is not required but now you are in linux, and if something doesn't work you should immediatly think that maybe doesn't work because you forgot to give the permission to work

Subscribe to Comments for "Please help get python-fu running in Ubuntu 10.4"