You are here

I can open only GIMP XCF and no other image

Please, could somebody help me ? I installed new version of GIMP on WinXP and I can not open JPG, PCX,... - only GIMP XCF.
In list of supported image files in Open dialog is only automatic and XCF. On another PC it is with no problem. only on my notebook. Maybe some old libraries on my computer ? I tried to install older version and it is the same - only XCF. After uninstall and install - the same- only XCF.
If I try in Open dialog All files and click on JPG, Gimp writes "...unknown file format".
Thank for some help.
Martin

P.S. In attachment is picture of Open dialog...

Forums: 

The file format plug-ins are usually situated in the Program Files folder (eg. C:\Program Files\GIMP-2.0\lib\gimp\2.0\plug-ins)


In the Preferences > Folders > Plug-Ins, you should add this folder into the list.. then restart GIMP.


Not sure why this folder is not automatically listed when installed, though, when it should be the default. :(

Regards,
Giraldi Maggio

The folder is listed there by default.

Hello,

I had the same problem on my new machine with Win7. The GIMP would start, but no plug-ins were available and I could only load .xcf files. Examined the preferences and everything was set-up correctly. Then, just as a last resort of desperation, I disabled "Defense+" in COMODO firewall and GIMP is working again!

Hi all, I found this thread while googling for some time about the same issue.

I believe there could be an issue with the dlls, and where they are registered in windows.
I have the same issue with both gimp 2.6.11 std, 2.6.11 rev3 Portable and 2.6.10 rev2.

My troubles began to occur while (trying to install the texturize plugin) I encountered an error: could not find XXX.dll

I downloaded XXX.dll, about 3 diff ones (iconv.dll, and intl.dll were, I think the other 2) and (I think) registered them.

Now I get: "The procedure entry point g_dir_open_utf8 could not be located in the dynamic link library libglib-2.0-0.dll" all the time with Gimp Std,
OR
none of the plugins work in Portable: (like loading a jpg or png) in Protable version... still looking for the solution.

Oh, and I have reinstalled Gimp several times too, including the fresh install as in the Gimp FAQ.

Windows 7 64 Ultimate

MAYBE you try to use plugin compiled for gimp 2.7 with gimp 2.6 but they may require different dll

about the dll location you should NOT install the dll globally (as in Windows/System or System32 or 64 ) but again if extra dll are required (and not included in the plugin download )that means you are using plugins compiled for older or newer Gimp version

Adding dll is a very hackish solution even if should work, anyway in this case i believe gimp will search that dll in its "bin" folder...(here not 100% sure the other possibility is the plugin folder )

But for sure you should not add them to the Windows dll

of these - ibglib-2.0-0.dll
In Gimps path.

Check in your user/gimp-2.6/plug-ins folder for that DLL if its there delete it.Gimp has one in the bin folder in it's own directory already.

Many problems with plug-ins and opening Gimp error from this same situation.I encourage you all to check the DLL files you download with plug-ins to make sure you do not already have them (library files), installed with Gimp.Or if they are not already in your systems path.(in your systems folder)

When trying to install the plug-in, all you should do it to copy it to a plug-ins folder (the GIMP preferences will tell you where exactly those are located on your system).

A common mistake is to try to start the plug-in executable directly - this is done by GIMP.

have youguys tried the GIMP forums available...lots of help from well qualified experts in them..and there are quite a few to find in google.

If the old libraries are the problem you should try using something like the regcure and have your system cleaned. Usually it works like a charm, so I am sure it will help you too.

Subscribe to Comments for "I can open only GIMP XCF and no other image"