You are here

YUV Temperature Plugin

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!

This plugin changes the color temperature of an image via shifting it in the YUV color space:

Compile and install it with:
$ CC="g++ -O2" gimptool-2.0 --install elsamuko-temperature.c

Menu entry is Colors -> Color temperature.

Windows binaries from François or Sylvie:

Mac binaries (for the macports GIMP):

Example of a warm setting with lowered exposure:

The YUV color space with the shift, the plugin does:
(cc) Tonyle/Wikipedia

If you like this, hug someone.

For all scripts together, go here:

elsamuko-temperature.c15.47 KB
GIMP Version: 
Code License: 



I am unable to install this on Vista. I get the following error:

The procedure entry point g_malloc_n could not be located in the dynamic link library libglib-2.OO.dll.

It uninstalls fine. Looks like a great tool that I would love to use!

Any suggestions?


here:, they write "Since 2.24", so I would say you have old version of glib...(2.0 according to name of dll)

Thank you, Samuel.
Compiles and works great on Windows too.
I'll add it to my "Gimp Win32 installers" page.

Thank you, Elsamuko!

Did you succeed building a Windows version of gimp-lensfun, samj?


Je veux bien essayer de compiler gimp-lensfun mais où se trouvent la bibliothèque et la base de données lensfun ? Existe-t-il une archive ?

Citation :
GimpLensfun is a Gimp plugin to correct lens distortion using the lensfun library and database.

Works well, thanks...

$ gimptool-2.0 --install elsamuko-temperature.c
gcc -pthread -I/usr/include/libpng12 -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/gimp-2.0 -I/usr/include/gtk-2.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/lib/gtk-2.0/include -o /home/avp/.gimp-2.7/plug-ins/elsamuko-temperature elsamuko-temperature.c -pthread -L/usr/lib/i386-linux-gnu -lgimpui-2.0 -lgimpwidgets-2.0 -lgimpmodule-2.0 -lgimp-2.0 -lgimpmath-2.0 -lgimpconfig-2.0 -lgimpcolor-2.0 -lgimpbase-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lm -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
elsamuko-temperature.c:73:23: error: expected ‘;’, ‘,’ or ‘)’ before ‘&’ token
elsamuko-temperature.c:82:23: error: expected ‘;’, ‘,’ or ‘)’ before ‘&’ token
elsamuko-temperature.c: In function ‘temperature_region’:
elsamuko-temperature.c:319:5: error: ‘RGB’ undeclared (first use in this function)
elsamuko-temperature.c:319:5: note: each undeclared identifier is reported only once for each function it appears in
elsamuko-temperature.c:319:9: error: expected ‘;’ before ‘rgb’
elsamuko-temperature.c:320:5: error: ‘YUV’ undeclared (first use in this function)
elsamuko-temperature.c:320:9: error: expected ‘;’ before ‘yuv’
elsamuko-temperature.c:345:16: error: conflicting types for ‘i’
elsamuko-temperature.c:317:11: note: previous declaration of ‘i’ was here
elsamuko-temperature.c:345:5: error: ‘for’ loop initial declarations are only allowed in C99 mode
elsamuko-temperature.c:345:5: note: use option -std=c99 or -std=gnu99 to compile your code
elsamuko-temperature.c:347:17: error: ‘rgb’ undeclared (first use in this function)
elsamuko-temperature.c:348:21: error: ‘yuv’ undeclared (first use in this function)
elsamuko-temperature.c:359:9: error: ‘for’ loop initial declarations are only allowed in C99 mode

Did you use recommended command with setting: CC="g++ -O2" before gimptool command itself?
For me it compiled without issues, but compile command started like this:

g++ -O2 -pthread -I/usr/include/gimp-2.0 .....

your command starts with :

gcc -pthread.....


Subscribe to Comments for "YUV Temperature Plugin"