You are here

Line Border 2

  • 1
  • 2
  • 3
  • 4
  • 5
Total votes: 0
Rate this item!
AttachmentSize
LineBorder-2.4.2.zip70.44 KB

A python conversion of my script-fu Line border script (http://registry.gimp.org/node/118). This version uses python-glade dialogs. It allows to create smaller and much clever input dialog and integrate much more functions. On other side, due to missing support of glade dialogs from Gimp, there is not possble to run this script in batch mode.

Current features:

  • All sizes could be specified in pixels or percents
  • Border corners and lines corners could be rounded
  • Multiple lines of text
  • Different font for eeach text
  • Texts coud be also placed on left, right or upper border
  • A watermark support (text or logo)
  • Translations (cs, nl)

If you found a bug or have a wish, please let me know. Thanks.

TODO:

  • Profiles (create/update/delete/rename)
  • Fill border with pattern
  • Allow to put Exif information inside the border
  • Allow batch mode
  • Use own script parameters dialog (Glade)
  • Allow more text options (each text in different font...)
  • Large border also in % of image Angle with round (if possible) (JacqDjo)
  • Sign (text,and color) in image with choice corner (JacqDjo)
  • Put text on right border of image instead under
  • Translations

INSTALLATION:

You need a gimp with python support installed.

Linux:

  • Extract content of the zip archive to the ~/.gimp2.6/plug-ins/ directory
  • Make script executable (chmod og+x ~/.gimp2.6/plug-ins/kym-Border.py
  • Script is installed under Filters/Decor/Borders/ as Line Border 2

Windows:

Please follow great step-by-step guide from E. Sullock Enzlin at http://registry.gimp.org/node/24503

SCREENSHOTS:

a GUI:

Multiple rows of text:

Text on right border

Text on upper border, rounded cornes

An watermark logo inside the image

A watermark text inside the image

Inner corners rounded

CHANGELOG:

04.01.2012 - v2.4.2

  • NL translation updated - thanks to Elmar
  • German translation added - thanks to Gudrun Schymiczek
  • Fix: Watermark image does not work

05.09.2011 - v2.4.1

  • FIX: fix Glade-3.10 issue

02.09.2011 - v2.4

  • ADD: profiles
  • ADD: Swap colors button
  • ADD: French translation (thanks to Brigitte Barbet)

03.11.2010 - v2.3

  • CHANGE: GUI improvement - Border page redesigned
  • ADD: Border corners could be rounded
  • ADD: Translations - cs, nl
  • CHANGE: correct issues with extreme values
         (e.g.: border width = 0 - a panorama style)

28.10.2010 - v2.2

  • ADD: allow to put sign/watermark inside the image

25.10.2010 - v2.1

  • CHANGE: use own glade dialog
  • CHANGE: remember plugin setting between sessions
  • CHANGE: Text could have more lines
  • ADD: posibility to place text on sides and on upper border
  • ADD: sizes could be in pixels or in percents
  • ADD: corner rounding

12.10.2010 - v2.0

  • Initial conversion to python
Code License: 
GIMP Version: 
Scripting Engine: 

Comments

but i had to add python 2.6 to Adaptable Gimp 2.6.10, and use that version.
Works excellent. :)

Hi,

I have installed the files as per your instructions, but now I cannot locate them in the GIMP's gui. They are not there where you have said (Filters/Decor/Borders/). In fact there is no sub-menu of Borders in Decor. I am relatively new to linux and GIMP so please excuse if this is very simple.

Thanks,
hrishi

Hi,
what operating system are you using? Do you have python installed? Does any other python plugin works for you?

Hi,

Thanks for your prompt response.

Apologies for not mentioning it before hand. I am using Ubuntu 11.04. Yes I have python installed. Another python plugin which I downloaded recently, feca_hdr seems to work well (I am assuming it is named 'HDR Tone Mapping' at Python-fu/render/HDR Tone Mapping).

The file kym-Border.py is located in '/home/hrishi/.gimp-2.6/plug-ins/LineBorder-2.3'

Also, when I couldn't see it on my GUI, I also made the file LineBorder.py in the path '/home/hrishi/.gimp-2.6/plug-ins/LineBorder-2.3/LineBorder' executable, but without success.

Thanks,
hrishi

Could you try to start gimp in terminal? Maybe there are some useful error messages.

More chances of useful messages starting gimp in verbose mode, to do it just write :

gimp --verbose

in the terminal

I did open it in the terminal. I used sudo gimp command and then later on gimp --verbose as suggested by you. Unsuccessful. I tried searching for the plugin in plugin browser, but without luck. Also, I had downloaded package for DustCleaner, another executable plugin. I have been unable to make it work either. So basically I think it is the file location and or the commands I am using which is the cause, rather than the plugins itself. Does LineBorder2 require any additional libraries? Also, I wanted to mention that I am using Python 2.6 and 2.7. Does this plugin require 2.5?

thanks,
hrishi

Uaaaaaa. I had a reply for you. but stupid spam filter think, I'm an spammer :-(

Reduced reply: look to Gimp options dialog, there is plugins directory setting.

Edit: See message 2 on http://pastebin.com/DPPqB01L

It doesn't require 2.5, but it does 2.6 series (2.6.4 or 2.6.5 seem to work best, I use 2.6.5). Having two versions of Python (not knowing your set-up, you may be conflicting Python versions with GIMP). 2.7 Python will not work with plug-in scripts written for GIMP 2.6.

Pages

Subscribe to Comments for "Line Border 2"